En visitant ce site, vous acceptez l'utilisation de cookies afin de vous proposer les meilleurs services possibles.

Paybox SH ?

il y a 2 ans 10 mois #1 par futurimedia
Paybox SH ? a été créé par futurimedia
Bonjour,
J'utilise depuis 2013 un module (que j'ai acheté à l'époque) de paiement pour Paybox, développé par Alatak (au moins dans une version 1.0 avant que ce soit intégré à AIO.
Pendant 5 ans il a très bien fonctionné.
Le principe est l'exécution d'un script placé dans un répertoire CGI externe au site.

Nous envisageons une grosse migration vers 3.0/3.2.
Mais là, aucune modif n'a été faite sur la structure depuis plus d'un an...

Or, depuis quelques semaines, Paybox ne répond plus... Lors du paiement dans Virtuemart, le script se déroule puis se bloque en disant qu'il ne peut accéder à un serveur "php".

J'ai activé le mode débug afin de collecter des infos. Voici donc l'erreur exact :
error:
getPayboxServerAvailable : no server are availablearray ( 0 ⇒ 'tpeweb.paybox.com', 1 ⇒ 'tpeweb1.paybox.com', )

Cette adresse tpeweb.paybox.com doit être donnée par le script. Mais ce serveur semble indisponible. Y a til un lien avec le fait que le service soit lié aujourd'hui à Verifone ?

Merci d'avance.

Alain
Quelqu'un a-t-il été

Connexion ou Créer un compte pour participer à la conversation.

il y a 2 ans 10 mois #2 par studio42
Réponse de studio42 sur le sujet Paybox SH ?
Dans une des derniéres version:
'tpeweb.paybox.com', //serveur primaire
'tpeweb1.paybox.com' //serveur secondaire

Par contre dans le nouveau code, il me semble que le script à complétement changé et utilise plus CGI.
Et la nouvelle adresse de base est tpeweb.paybox.com/php/
Donc en migrant vers VIrtuemart 3.2 cela doit fonctionner

www.st42.fr Truc et astuce Joomla et virtuemart
shop.st42.fr téléchargement Joomla et extension pour virtuemart
Gratuit ! Nettoyage des medias : shop.st42.fr/fr/produits/virtuemart-netoyage-des-medias.htm Nouveau!
Les utilisateur(s) suivant ont remercié: futurimedia

Connexion ou Créer un compte pour participer à la conversation.

il y a 2 ans 9 mois #3 par futurimedia
Réponse de futurimedia sur le sujet Paybox HS ?
Merci de la réponse.
Je viens d'obtenir une réponse par ailleurs. Le problème vient de l'usage nouveau fait par Paybox du protocole TLS 1.2.
L'arrêt du support TLS 1.1 faisait planter le script Paybox, car mon hébergement OVH en mode Legagy ne supporte pas TLS 1.2. Il faut donc modifier chez OVH pour demander un environnement stable et non plus legacy pour le site. Et là, Paybox fonctionne à nouveau.
Il faut donc relire 4 fois la méthode et prendre 3 alka selzer pour y parvenir... Mais ça marche.
Personne d'aurte que le client final n'a été informé de cette disposition et lui son truc c'est plutôt les motos et le cambouis...

Connexion ou Créer un compte pour participer à la conversation.

Le nom Joomla!® et son logo sont utilisé sous licence limitée d'Open Source Matters, le propriétaire mondial de la marque de commerce. Le site VirtueMart.fr n'est pas affilié ni soutenu par Open Source Matters ou le projet Joomla!®.
VirtueMart est une marque déposée par iStraxx UG (haftungsbeschränkt) en Allemagne.